Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

TypeLocationStatus QuoProposed Action

AbstractApp

 

info.magnolia.ui.framework.appabstract but many subclasses (e.g. PagesApp, MessagesApp) don't add additional functionalityconvert to non-abstract type & rename to BaseApp, DefaultApp or AppImpl. Get rid of most subclasses. Inject the AppContext and App(Frame)View directly into the AbstractApp instead of passing it from the AppClass.
AbstractContentAppinfo.magnolia.ui.admincentral.app.content

see AbstractApp

convert to non-abstract - e.g. PagesApp or ConfigApp could go

Used for opening the ChooseDialog. A relict from the time we had the workbench definition bound to the App.

Remove class and create an interface for ChooseDialog

The idea of this class was serving the workbench configuration, as this has moved to the subApp there is no real usage for this class. The logic in there for serving a ChooseDialog hould be moved to an interface, so that the actual implementation of opening the Dialog is up to the App and not bound to the framework.

AbstractSubAppinfo.magnolia.ui.framework.appsee AbstractAppconvert to non-abstract - e.g. PageMainSubApp could go
AbstractItemSubAppinfo.magnolia.ui.admincentral.app.contentsee AbstractAppconvert to non-abstract- e.g. ContactsItemSubApp could completely go then
AppController 

The App controller that manages the lifecycle of running apps and raises callbacks to the app.
It provides methods to start, stop and focus already running {@link App}s.
Registers handlers to the following location change events triggered by the {@link LocationController}:

  • LocationChangedEvent
  • LocationChangeRequestedEvent

 

  • The AppController takes care of LocationChangedEvents coming from info.magnolia.ui.admincentral.app.simple.AppControllerImpl#onLocationChanged which can for example be fired by the info.magnolia.ui.framework.location.LocationController#goTo when clicking on icon in the AppLauncher. It takes the Location passed and extracts AppName and subAppId and gets the corresponding AppDescriptor from the info.magnolia.ui.framework.app.launcherlayout.AppLauncherLayoutManager.
  • It creates a new AppContext for the App
  • keeps history of running app and currently focused app
  • used by the MagnoliaShell to query the current Status of the appController
  • Used by FieldBuilders to get the AppContext and ComponentProviders for opening ChooseDialogs.
  • input from frist review
    • should not have a dependency to the ui classes (layout)
    • has to make sure a user have permission to run an App (-> not in Layout)
    • construction of an app can be specific (able to overwrite)
  • usage of FocusEvent: seems to not be used consistently. Could also be extended to get rid of the setViewPort and associated calls
  • usage of appId is should be changed to appName
  • some methods take the appId and the location as parameter, appId is part of the location
  • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#setViewPort
    • use focus event instead?
  • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#getAppWithoutStarting
    • apparently the idea was to actually start the app for this usage
  • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#startIfNotAlreadyRunningThenFocus
    • only used in test cases. see general question about focusEvent
  • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#startIfNotAlreadyRunning
    • deprecated, maybe not right, see focusEvent
  • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#doStartIfNotAlreadyRunning
    • this also checks if the app is running, if so it delegates to that app.. wrong naming
  • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#stopApp
    • only used internally
    • info.magnolia.ui.admincentral.app.simple.AppControllerImpl#onLocationChanged
      • too heavy, should delegate to methods rather, see focusEvent
AppContext 

The AppContext serves multiple different purposes:

  • An app uses the AppContext to interact with the App Framework. Some examples:
    • resolve the configured App Label for setting the correct title in the tab.
    • send notification Messages to the MessagesManager
  • The AppController uses it to delegate handling of location changes and to the app and subApp
  • Takes care of reading subApp configurations and mapping locations to to the correct subApp
  • creates both componentProviders for App and subApp

The general problem: used heavily by the appController and also for the app itself to get contextual information: serving multiple needs. see 

Jira
serverMagnolia
keyMGNLUI-403

  • The idea of AppContext is to expose functionality to the App. That is, to an instance of an app.

    It should not expose methods that are only used by AppControllerImpl. These should be hidden from all other classes.

    If necessary AppControllerImpl#runningApps should be changed to <String, AppContextImpl>. Also if the intention of AppContextImpl is unclear it should be renamed to reflect the fact that is not just the default implementation of AppContext, it does much more and in fact fullfils much of the contract defined by AppController.

  • rename the AppController to AppLauncher or similar, introduce a new AppController class which takes care of the contract to the AppLauncher and keep the AppContext as thin as possible, only serving contextual information to the actual App
  • Move some of the functionality of AppContext into the info.magnolia.ui.framework.app.launcherlayout.AppLauncherGroupEntry
    • info.magnolia.ui.admincentral.app.simple.AppContextImpl#getDefaultSubAppDescriptor
    • info.magnolia.ui.admincentral.app.simple.AppContextImpl#getSubAppDescriptorById
AppContextImpl  
  • find better name, it's more than an Impl of an AppContext
    • Tobias' propsal: rename AppController -> AppManager & AppContextImpl -> AppController
  • check whether AppContextImpl can go to framework (after package restructuring)

SubApp All SubApp's are considered to be equal. We can flag one (or even more) to be the default - that's the one that will be opened first and that won't be closable.
  • It should not be configurable what SubApp is the main. Wouldn't work e.g. for PagesApp if the editor would be the main (you don't get back to overview). 
  • No App without a "Main Subapp"! SecurityApp (only subapps of same level) will have to change - discussed with Andreas + Philipp
  • Should Main Subapp be an explicit type - or inlined in real App?
    • we don't want to be able to overwrite
SubbAppContext Basically in good shape - just offers a little too much.

Eliminate methods only relevant for the implementing types - not for someone writing an app.

Basically we should question all setters on this interface.

  • e.g. setAppContext(AppContext)
    • this should automatically happen behind the scenes (in the impl) - don't see why someone should explicitly call it from outside

AppDescriptor

SubAppDescriptor

 simply used for config
  • trivial: create common super-interface (class for the Configured impl's) - 90% of the code is identical
  • replace explicit setting of default by order of subapps?

...